0

I tried to login gpgs using cocos2d-x and sdkboxplay but I get the following error.

****

**** APP NOT CORRECTLY CONFIGURED TO USE GOOGLE PLAY GAME SERVICES
**** This is usually caused by one of these reasons:
**** (1) Your package name and certificate fingerprint do not match
**** the client ID you registered in Developer Console.
**** (2) Your App ID was incorrectly entered.
**** (3) Your game settings have not been published and you are
**** trying to log in with an account that is not listed as
**** a test account.
****
**** To help you debug, here is the information about this app
**** Package name : com.jeun.sdkplay
**** Cert SHA1 fingerprint: F8:08:BF:~~~0:CF:33:71:9F:~~~~~~
**** App ID from manifest : 764~~~~~~
****
**** Check that the above information matches your setup in
**** Developer Console. Also, check that you're logging in with the
**** right account (it should be listed in the Testers section if
**** your project is not yet published).
****
**** For more information, refer to the troubleshooting guide:
**** http://developers.google.com/games/services/android/troubleshooting

W/SdkboxGPGAuthentication: sign in failed:4 null

 

I see that the google play setting is incorrect, but I do not think there's anything wrong with the setup. This is because you have already logged in using sdkbox gpgs. I want to use sdkbox play because i will use ios' game center.

Please help me .. I am suffering for three days.

 

My environment os x xcode 9.2, android studio 3.2.1 cocos: 3.17.1 sdkbox 2.4.3.3

yinjimmy answered
    0

    you use both sdkboxplay and gpg ?

     

    more things:

    1. edit sdkbox_config.json to disable cloud_save

      "cloud_save": false
    2. add you account as tester or developer.
    3. http://docs.sdkbox.com/en/qa/sdkboxplay_troubleshoot/
    yinjimmy answered

      Question stats

      • Active
      • Views321 times
      • Answers1 answer
      • Followers1 follower

      Categories