I keep getting strange crashes using sdkbox + admob plugin. And crash seems to be somewhere inside sdkbox internals.

They happen only on Iphone7 and it seems that it happens when banner is not loaded and when sdkbox wants to output a debug message.

Also on iphone4s (ios9) I get wrongly formated error messages-

SDKBOXADS :Placement \354:\310 has no units with ads.

SDKBOXADS :Placement \330:\214 has no units with ads.

Question- has someone seen something similar? Any ideas why that could be happening?

I also tried the latest AdMob SDK (7.15.0) + latest sdkbox versions, but it did not help.

Also another question- is SDKBox closed source or open source? Is it possible to access the source somewhere or at least get debug versions for the framework?

Steve Seidel answered

    Perhaps, I'm missing something too, as I've a test project with sdkboxads. I tested it with the suggested zip file http://discuss.cocos2d-x.org/uploads/default/14434/44bce6845d89728f.zip from this topic posted by fast essay writer, but in vain. What else can I do?


    Steve Seidel edited answer

      Seems the fix worked, tough I saw no adverts on iphone7, but probably it's admob serving them, not sdkbox, but there were no crashes and on other devices and simulator ads were displayed ok.

      So- does this means it was bug in sdkbox? And if yes, then when can we expect fixed version?

      nite commented
        yinjimmy 1.17K Rep.

        can u try this framework ?



        what's your placement id ?

        yinjimmy edited answer

          there's the screenshot:


          kovacsx edited answer

            Question stats

            • Active
            • Views2549 times
            • Answers4 answers
            • Followers2 followers